windows系统如何选择apache和php版本

[php] 2022-08-16 圈点328

摘要:有时候经常要建apache(httpd)和php的环境,一键安装虽好,可很多东西都无法掌控和方便学习。一直以来都是手动配置apache(httpd)和php环境。也跳过好多坑,这里记录关于apache和php版本的选择问题。

有时候经常要建apache(httpd)和php的环境,一键安装虽好,可很多东西都无法掌控和方便学习。一直以来都是手动配置apache(httpd)和php环境。也跳过好多坑,这里记录关于apache和php版本的选择问题。

对于apache(httpd)很好选择了,现在基本都是2.4版本,2.2基本上不用了。而php版本的选择就要注意了。


第一坑:选择对应版本的位数。

apache(httpd)官方已经不提供编译好的软件直接下载和安装包了,如果要使用原版就得自己编译。当然也有一些站会提供一些编译好的软件包,不过发现一个问题,相当一部分都只有32位的安装包,如果安装了32位的apache(httpd),在选择php版本的时候,最好也要选择32位的版本。


第二坑:php版本中的nts和ts版本选择问题

按照经验nts版本会在文件名中写明nts,但ts版本很可能不会在文件名中写ts,所以没有写明的一般就是ts版本。

php的这两个版本的区别挺多解释,不过很少有提到如下情况,只有在php的ts版本中有“php7apache2_4.dll”这个文件(如果是php5此文件名为“php5apache2_4.dll”),所以如果apache以module方式加载php,就必须要使用ts版本。

apache  php  

感谢反馈,已提交成功,审核后即会显示